우분투 파이어폭스에서, 로지텍 M510 마우스 사이드 버튼 설정

사용자 삽입 이미지제가 쓰는 마우스가 로지텍의 MX510인데요, 이 마우스는 브라우저에서 페이지 앞뒤로 전환할수 있는 편리한 버튼과 페이지 업다운, 프로그램 전환등의 다양한 보조 버튼들이 있습니다. 그런데 우분투에서는 이게 자동으로 인식되지 않습니다. 설정 방법을 인터넷에서 찾아봤지만, 워낙 여러가지 방법이 많고, 그중에는 부팅시 에러를 유발하는 잘못된 방법도 많습니다. 그래서 제대로된 방법을 찾는데 오래걸렸네요.

xorg.conf를 수정합니다. 백업은 습관.

sudo gedit /etc/X11/xorg.conf

마우스 부분 코드를 찾아 수정합니다. (붉은 색 부분)

Section “InputDevice”
        Identifier      “Configured Mouse”
        Driver          “mouse”
        Option          “CorePointer”
        Option          “Device”                “/dev/input/mice”
        Option          “Protocol”              “auto”
        Option          “Buttons”               “7”
        Option          “ZAxisMapping”          “4 5”
        Option          “ButtonMapping”         “1 2 3 6 7 4 5 6”
EndSection

수정후 저장하고 X를 재시작합니다.

출처는
http://ubuntuforums.org/showthread.php?t=485175

이 방법은 MX510외에도
*LogiTech G5
*LogiTech wireless Media Play
*MX600 cordless laser
*MX610 laser
등에 사용할수 있다고 원문에 써있는데, MX500도 MX510과 같은 구성이니 쓸수 있을겁니다.

ps.
파이어폭스3는 버튼 매핑이 바뀌었다.

Section “InputDevice”
        Identifier      “Configured Mouse”
        Driver          “mouse”
        Option          “CorePointer”
        Option          “Device”                “/dev/input/mice”
        Option          “Protocol”              “auto”
        Option          “Buttons”               “7”
        Option          “ZAxisMapping”          “4 5”
       Option          “ButtonMapping”     “1 2 3 8 9”
EndSection

글쓴이 : Draco (https://draco.pe.kr)
크리에이티브 커먼즈 라이선스 이 저작물은 크리에이티브 커먼즈 저작자표시 4.0 국제 라이선스에 따라 이용할 수 있습니다.

You may also like...

4 Responses

  1. 재성才誠 댓글:

    안녕하세요.

    드디어 집에 와서 마우스 설정해보려고 파일을 열었는데 전

    Section “InputDevice”
    # generated from default
    Identifier “Mouse0”
    Driver “mouse”
    Option “Protocol” “auto”
    Option “Device” “/dev/psaux”
    Option “Emulate3Buttons” “no”
    Option “ZAxisMapping” “4 5”
    EndSection

    라고 설정이 되어 있네요. 지금 해보니 왼쪽 보조 버튼이 모두 인식되고 있습니다. 그럼 그냥 문제 없는 건가요? (대뜸 나타나서 이상한 질문해서 죄송합니다. ㅠㅠ)

  2. 남성 댓글:

    전 현재 Wubi 깔아서 우분투 쓰고 있는데 제대로 마우스가 제대로 인식이 안되네요… 흠 암튼 위 내용 함 시도 해 봐야 겠네요